How to Hide MacOS Catalina from Software Update on Mac

Oct 16, 2019 - 44 Comments

How to hide MacOS Catalina update on Mac

Want to stop MacOS Catalina showing up in Software Updates on a Mac? Don’t plan on updating to MacOS Catalina anytime soon? Still up in the air about whether or not to update to MacOS Catalina 10.15?

If you don’t want the “MacOS Catalina” update to show as available to download in the Software Update section of macOS, you can use a terminal command to block and hide the software update from showing as available. This can be helpful if you’re avoiding installing MacOS Catalina for whatever, whether to avoid potential problems, or if you just don’t want to deal with updating to it anytime soon.

How to Stop MacOS Catalina Showing in Software Update on Mac

  1. Quit out of System Preferences
  2. MacOS Catalina shown as available upgrade

  3. Launch the Terminal application on the Mac, found in /Applications/Utilities/ folder
  4. Mac Terminal icon

  5. Enter the following command at the Terminal command line:
  6. sudo softwareupdate --ignore "macOS Catalina"

  7. Hit return then enter the admin password * and hit return again to execute the command with super user privileges
  8. How to hide MacOS Catalina update

  9. Re-open System Preferences, the “MacOS Catalina” update will no longer show as available
  10. MacOS Catalina is hidden

Now MacOS Catalina update will remain hidden from Software Update on the Mac until this setting has been changed, which we’ll discuss further below.

With MacOS Catalina no longer taking up the primary “Software Update” screen, you’ll continue to be informed of incoming software updates for Security Updates, Safari Updates, iTunes updates, and any other software releases for the currently running MacOS version.

If you have ignored the MacOS Catalina upgrade you can also continue to selectively install specific software updates via Mac Software Update.

Any future software updates that are not Catalina will continue to be available, or install automatically if you have that feature enabled.

Note you may wish to download MacOS Catalina installer before ignoring the software update, for convenience, if you plan on installing it down the road, or onto another computer, or making a USB boot drive, or whatever else. Of course you can also make the upgrade show as available in Software Update again if you’d like to, as we’ll cover next.

How to Make MacOS Catalina Upgrade Available in Software Update Again

To unhide MacOS Catalina and make the MacOS 10.15 update available again, you can do one of two things. One is to start the process of downloading MacOS Catalina from the Mac App Store, but since we used the command line to ignore the update the best approach is to return to the Terminal.

To make MacOS Catalina upgrade show up in Software Update again, return to the command line and clear and reset the ignored software updates list with the following command line syntax:

sudo softwareupdate --reset-ignored

Again authenticate with the admin password and hit return.

Relaunching System Preferences and returning to Software Update will make MacOS Catalina show as available again, just like any other system software update in modern MacOS versions like Mojave (or Catalina).

Did you ignore the MacOS Catalina software update? Why or why not? Do you know of another method to block or hide the MacOS Catalina update on a Mac? Let us know your experiences in the comments below.

Enjoy this tip? Subscribe to the OSXDaily newsletter to get more of our great Apple tips, tricks, and important news delivered to your inbox! Enter your email address below:

Related articles:

Posted by: Paul Horowitz in Mac OS X, Tips & Tricks, Troubleshooting

44 Comments

» Comments RSS Feed

  1. Vince says:

    This Catalina is a sad update if you use your Mac for any kind of work.

    The super new features it touts are aimed at media consumers, couch potatoes, people who watch movies and listen to music and apparently do very little else.

  2. Jos Moody says:

    For everyone asking about removing the red dot that says there is an update available even after ignoring the Catalina update simply open the terminal and enter:

    defaults write com.apple.systempreferences AttentionPrefBundleIDs 0

    This should take care of it. You may also need to restart the dock with:

    killall Dock

  3. ateet says:

    thanks but it still shows the red dot with”1″ on the icon in the doc.
    how to get rid of that?!

  4. Dominic says:

    Great! Thanks for the tips.

  5. Lexiepex says:

    If you can not put in your password when doing the Terminal command:
    do the command WITHOUT the sudo.

    • Paul says:

      If you want to hide the macOS Catalina update from the Mac you must use the command as written with sudo.

      You can always put in the password when using sudo to execute the command to hide Catalina update, typing the password does not show up when you type it as a security mechanism that pertains to all sudo use and command line logins.

  6. Jay says:

    I have tried this command in terminal numerous times, using the exact spacing you show on the screen. NOTHING HAPPENS.

    I have then even dragged it of of the dock, but it comes back. Is the spacing incorrect?

    • Paul says:

      You have to type the command exactly. It works to hide MacOS Catalina update. If you are doing something wrong, that is user error.

  7. JeffP3456 says:

    I believe this is an apple bug (no surprise sadly). I copy/pasted the command and I am quite comfortable with using the terminal and it claims to have worked.
    If I subsequently do a softwareupdate –list it says no software available but I have a red dot on the syspref icon and also 1 update available in the apple menu.
    if I open system preferences and click on software update it tells me that my Mac is up to date Mojave 10.14.6
    so there you have it the continued slow decline of MacOS.

    • RonT says:

      I totally agree with everything JeffP3456 says. How do I get rid of the red dot on the syspref icon and also 1 update available in the apple menu? And also the annoying daily reminder to install the update now or later.

  8. Jones says:

    Thanks! On our audio (Logic) production machines: many pieces of software are still running in 32bit, it’s a big deal / mess to upgrade everything, not to mention the cost for multiple systems. Plus there doesn’t seem to be any benefit going from Mojave to Catalina on a dedicated audio machine. iCloud is disabled, and alot of consumer esq features are never used.

    Glad Catalina wont be sitting there as an upgrade option anymore.

  9. Bobber says:

    I’m a little late with this comment, but for the folks saying it doesn’t work, note that you must be logged in to your admin id for the tip to work. If you are on a non-admin id (as you should be for day to day work), MacOS’s default settings do not permit sudo to be run.

  10. Peter says:

    same problem here. a red dot in the dock and 1Update under the Apple menu.
    How could these indicators be wiped out? I guess the ignore command only hides Catalina but the gui for showing an update status tales its info from somewhere else.

  11. Kevin Roa says:

    Thank you.

  12. Jenna says:

    Thank you for this! I have a boatload of 32-bit apps so don’t want to upgrade, plus I’m concerned that my Macbook Pro is the very oldest model still supported by the upgrade, so it might be on the edge of what the computer’s capable of.

    • Neil Ferguson says:

      That is my situation too. Like some others, I’m very hesitant to use the Terminal Command. Instead of typing the listed code for hiding Catalina, I copied and pasted it and I do most of my password entries like that. Typing invisible code and words can be very risky. Thanks for the info, I succeeded in hiding the Catalina upgrade.

  13. Jay says:

    I tried the command twice. I cut and pasted the code, then I tried typing it it. Neither attempt worked.

    • Paul says:

      What happens? The terminal should give you some feedback as to what the command fails with.

      This works to ignore macOS Catalina update, I have used it on multiple Macs and can confirm directly. You must use exact syntax in the command line.

      Make sure in the Terminal it appears exactly:

      sudo softwareupdate --ignore "macOS Catalina"

      Hit return, then enter the admin password, hit return again.

      The command line is confusing to a lot of users who aren’t familiar with it, this is a bit more of an advanced tip but unfortunately since there is no other way to ignore the Catalina software update this is also the only way to do so (that I’m aware of anyway).

  14. Larry Wilson says:

    That worked but there are two other places that are displaying a flag/indicator of an update to install. First is under the Apple menu where it says system preferences… To the right if that it still says “1 update”. There is also a red dot on the system prefs dock icon. Any suggestions to get rid of those two annoyances?
    Thanks in advance.

  15. Jackie says:

    This workaround did not work for me. I am on a MacMini late 2014. I am not used to working with Terminal. When I type in the ignore command then enter, I get Password: and a key symbol. It will not allow me to type in my Admin password.

    I do not want to run Catalina as I am having issues with it to start with. I think that upgrading may cause additional issues. A new Mac is not on my horizon, so I need to baby this one.

    HELP!
    TYIA

    • Paul says:

      Hi Jackie,

      Please try again as the command does work to hide the MacOS Catalina update from appearing as a software update. What you are experiencing sounds like the terminal security feature that hides passwords when typed.

      Type the command exactly as shown in the article and then hit return. When asked for your admin password, type it at the prompt anyway, but yes it will not show up. After you type your password, hit Return/Enter to execute the command.

      The terminal intentionally does not display typed passwords as a security mechanism. You can read more about that specific feature here if interested: http://osxdaily.com/2015/02/04/terminal-wont-show-password-when-typed/

      Hope that helps!

      • Jackie says:

        I may not be typing this correctly (re: spaces where the – – appear). But this is what I get:
        Last login: Thu Oct 17 19:41:11 on ttys000
        JacquelinesMini:~ wilssearch$ sudo softwareupdate – – “macOS Catalina”
        Password:
        usage: softwareupdate [ …]

        ** Manage Updates:
        -l | –list List all appropriate update labels (options: –no-scan, –product-types)
        -d | –download Download Only
        -e | –cancel-download Cancel a download
        -i | –install Install
        … specific updates
        -a | –all All appropriate updates
        -R | –restart Automatically restart (or shut down) if required to complete installation.
        -r | –recommended Only recommended updates
        –background Trigger a background scan and update operation
        –ignore … Ignore specific updates
        –reset-ignored Clear all ignored updates

        ** Other Tools:
        –dump-state Log the internal state of the SU daemon to /var/log/install.log
        –evaluate-products Evaluate a list of product keys specified by the –products option
        –history Show the install history. By default, only displays updates installed by softwareupdate.
        –all Include all processes in history (including App installs)

        ** Options:
        –no-scan Do not scan when listing or installing updates (use available updates previously scanned)
        –product-types Limit a scan to a particular product type only – ignoring all others
        Ex: –product-types macOS || –product-types macOS,Safari
        –products A comma-separated (no spaces) list of product keys to operate on.
        –force Force an operation to complete. Use with –background to trigger a background scan regardless of “Automatically check” pref

        –verbose Enable verbose output
        –help Print this help

        JacquelinesMini:~ wilssearch$

      • Jackie says:

        Paul, I forgot to say thank you! Please, I noticed that I do not get the % sign after when starting terminal – get a $. Not sure if that makes a difference.

        • Paul says:

          Looks like you left off the –ignore syntax. The command line requires precise syntax or command will not execute (or not execute as expected, performing another result)

          sudo softwareupdate --ignore "macOS Catalina"

          There is no space between the two dashes and ignore.

          Hope that helps!

  16. Ken says:

    Thank you! You read my mind, and that of several thousand others, no doubt.

    Question: If at some future time I do install Catalina, will this block subsequent Catalina update notices?

  17. Art says:

    How do I do that for a security update that was done but continues to suggest repeatedly? (What name to use instead of the ‘Catalina’ shown above?)

    • Paul says:

      If it keeps suggesting the security update it likely didn’t install yet, so it’d be a good idea to backup the Mac and then install the update. You could also install it from a package updater downloaded from the Apple website.

      Anyway, you can ignore any update by changing the name of the update, be sure to use exact match syntax:

      sudo softwareupdate --ignore "Name of Update to Ignore"

  18. Margaret says:

    Anyone know if this stops the update Notification Banner that pops up several times a day? The instructions for stopping it on previous systems no longer work.

  19. Mark Hoggatt says:

    It is so sad that aPpLe chooses to operate this way. I never expected to say this, but I deeply regret ever having bought a Mac.
    This latest update makes me want to bite the bullet and revert to back to the surprisingly MUCH more stable windows OS fast, which I continue to use at work.
    The incessant Mac OS update experience has been disturbing.

  20. Rob says:

    Why would I want iPad or iPhone apps on my Mac? They are completely different devices with different uses. So why would I want Catalina? Also, for me, Mavericks has to be the last macOS unless I buy a new Mac, a new iPad, a new….

  21. Bill says:

    I just ran Terminal: sudo softwareupdate –ignore “macOS Catalina”
    and got:
    “RAWCamera25-2.5”,
    “RAWCamera20-2.0”,
    “iTunesX-8.2.1”,
    “RAWCamera24-2.4”,
    “RAWCameraUpdate3.8”,
    “RAWCamera23-2.3”,
    “macOS Catalina”,
    “RAWCamera22-2.2”,
    “RAWCamera26-2.6”,
    “RAWCamera21-2.1”

    • owan says:

      Those are the other software updates you have ignored over time.

      Remember to use two dashes for a flag:

      sudo softwareupdate --ignore "macOS Catalina"

  22. Daniel says:

    Igor, you can easily write a small script to execute that terminal command at login I do it with Time Machine to get rid of system Throttle.

    http://www.mackungfu.org/massively-speed-up-time-capsule-time-machine-backups

    If you replace the “no throttle” command with the command to remove the System Prefs Badge (and rename the nothrottle.plist), it works just fine.

  23. Yuhyo says:

    Cool finally I can ignore this goofy thing

  24. Steve says:

    Yes, the red badge is still there even after rebooting.
    What gives?

    • Igor says:

      You can hide the red badge on the System Preferences icon with:

      defaults write com.apple.systempreferences AttentionPrefBundleIDs 0 && killall Dock

      But unfortunately it will come back after every restart, so you have to continuously issue the command…

      I wish Apple made it easier to ignore an update. People should not be having to go into the Terminal to avoid a software update that breaks things that many people rely on (32-bit apps, removes Dashboard, removes iTunes, etc)

      • Tom says:

        How to remove the red badge after ignoring MacOS Catalina by terminal FOREVER (as discribed earlier):

        Quit Systemprefs

        Edit the file
        com.apple.preferences.softwareupdate.plist
        in your users/library/preferences folder with you preferred plist-editor.

        Remove the entry
        LatestMajorOSSeenByUserBundleIdentifier
        completely.

        Save the plist, restart system prefs and let it search for updates again. No more red badge, caused by the Catalina-Update …

        by the way: any new user won’t see the badge without doing this, if the Catalina-update is ignored …

  25. Paul says:

    I always wait to upgrade MacOS until the 2nd or 3rd version, so this tip was most welcome. Just one minor observation: The red dot still shows up on system preferences. Thanks again.

  26. RM says:

    Thank you so much!

Leave a Reply

 

Shop on Amazon.com and help support OSXDaily!

Subscribe to OSXDaily

Subscribe to RSS Subscribe to Twitter Feed Follow on Facebook Subscribe to eMail Updates

Tips & Tricks

News

iPhone / iPad

Mac

Troubleshooting

Shop on Amazon to help support this site