Angry Birds update adds older MacBook GMA 950 graphics support

Jan 12, 2011 - 7 Comments

angry birds mac update gma950 support

Angry Birds for Mac has just been updated to include support for older MacBooks, iMacs, and Mac Minis with the Intel GMA 950 graphics card.

Users who already bought Angry Birds from the Mac App Store will find the new version in your Updates list, otherwise new users can buy the game from the App Store (direct link). If you do not need the fix, it will not appear in the App Store Updates list.

Prior to this Angry Birds update, anyone using the older GMA950 Intel video card was unable to launch the game, which led to a series of one-star ratings on the App Store from frustrated users. Hopefully this will resolve all those complaints, because Angry Birds is really fun and makes a great desktop game, I’d recommend checking it out if you haven’t already.

Enjoy this tip? Subscribe to the OSXDaily newsletter to get more of our great Apple tips, tricks, and important news delivered to your inbox! Enter your email address below:

Related articles:

Posted by: Paul Horowitz in Games, Mac OS X

7 Comments

» Comments RSS Feed

  1. […] 2: Angry Birds for Mac has been updated to include GMA 950 graphics support, this resolves the compatibility problems with older MacBook, Mac Mini, and iMac […]

  2. Steampunk Jammer says:

    But you still have to be running Snow Leopard 10.6.6.

    • Jeff says:

      It requires 10.6.6 because it requires the App Store, there is no technical limitation to running on prior versions of Snow Leopard.

      Why not just update?

  3. ademsemir says:

    Another reason they might have done this, could be to fix the signature file or whatever its called, that allowed people to “hack” the game and use it for free.

  4. Will Apple Macbook says:

    I can see how having poor support led to a low rating, I would be annoyed if i had an older mac and it wasn’t supported. I now have Angry Birds on the iphone ipad and macbook, it’s a silly addictive game, turns my 5min revision breaks into hours.

  5. Bill M says:

    The 2.0.1 update that adds support for older Macs breaks the game for everybody else. Read the reviews on the UK and US App Stores. It’s completely unplayable now so don’t waste your money until Rovio fixes it.

    That might be a long time as from a number of the comments on the US App Store particularly, Rovio is saying that their introduction of the problems that make the game unplayable is actually a design feature!

Leave a Reply

 

Shop for Apple & Mac Deals on Amazon.com

Subscribe to OSXDaily

Subscribe to RSS Subscribe to Twitter Feed Follow on Facebook Subscribe to eMail Updates