JailbreakMe 3.0 is Now Available

Jul 6, 2011 - 12 Comments

JailbreakMe 3.0

After a long wait, JailbreakMe 3 has finally been officially unleashed, and it is without a doubt the easiest jailbreak ever to exist.

No computer is necessary, no downloading weirdly named jailbreak apps, no technical process, it’s just a matter of visiting Jailbreakme.com on your iOS device and the jailbreak installs.

JailbreakMe 3.0 compatible hardware includes iPad 2, iPad, iPhone 3GS, iPhone 4 GSM, iPhone 4 CDMA, iPod touch 3rd and 4th gen, ranging from iOS 4.3 or later, although the iPad 2 requires iOS 4.3.3 to work. Enjoy!

Update: Here’s a guide on how to jailbreak iPad 2, iPhone, and iPod touch with iOS 4.3.3 using JailbreakMe 3

Enjoy this tip? Subscribe to the OSXDaily newsletter to get more of our great Apple tips, tricks, and important news delivered to your inbox! Enter your email address below:

Related articles:

Posted by: Matt Chan in iPad, iPhone

12 Comments

» Comments RSS Feed

  1. cee202 says:

    Thank you so much, it worked!

  2. [...] JailbreakMe 3.0 is out finally and if you’re interested in jailbreaking this is what you’ve been waiting for; it is entirely computer free, there is no DFU mode, there is no restoring firmware and IPSW files, nothing complicated at all, just load the jailbreakme.com website from your compatible iOS device and the jailbreak installs. [...]

  3. [...] JailbreakMe 3 is out! It’s the easiest jailbreak ever and works to jailbreak iPad 2 running iOS 4.3.3. It is [...]

  4. M4sT3r RoKu says:

    Jailbreakme 3.0 is incredibly witty and ingenious but the only thing that bugs me is that its not for the iphone 3g. I thought that apple was the only people that would let older devices get the good stuff but now this…. people dont like being forced to buy new stuff when the thing they have is fine.

  5. plumber34 says:

    worked perfectly on my verizon iPhone 4 (4.2.6)
    I was wondering if i update to 4.2.8 if it would still work if anybody has has success or knows that it will work on 4.2.8 please leave a comment thanks.

  6. Ira says:

    I’m getting this error on my Verizon iPhone 4 when trying to install from jailbreakme.com after restoring my phone

    “not supported on your device. you can try here for an alternate version”

  7. Eldre says:

    Yeah my iPod touch 4g at first it didn’t have the install button, so I got iOS 4.3.4 I think something like that and it didn’t work and also now my iPod got a little slower what do I do I want jailbreak!

  8. Nemesis says:

    Does it work on the 4S ?

  9. Hussain says:

    Tried using iPad 2 4.3.2. The page says at the top: iPad 2 Not Supported.

    Tried the Cydia link anyway and got another page saying: Ooops, you are trying from an iPad 2.

  10. Lewis says:

    How about 4.2.1?

Leave a Reply

 

Shop for Apple & Mac Deals on Amazon.com

Subscribe to OSXDaily

Subscribe to RSS Subscribe to Twitter Feed Follow on Facebook Subscribe to eMail Updates