Unlock iPhone 3GS & iPhone 4 on iOS 5.0.1 with Ultrasn0w 1.2.5

Dec 21, 2011 - 10 Comments

unlock iOS 5.0.1 with ultrasn0w Ultrasn0w 1.2.5 has been released and it allows for unlocking some iPhone 3GS and iPhone 4 models with older modem firmware versions. Compatible baseband is as follows:

  • iPhone 4: 01.59.00
  • iPhone 3GS: 04.26.08, 05.11.07, 05.13.04, 06.15.00

You can check baseband on the iPhone by tapping on Settings > General > About and looking for “Modem Firmware” near the bottom of the About screen.

If your iPhone 3GS or iPhone 4 has eligible baseband and is already jailbroken, then you can just search Cydia for “ultrasn0w” and download and install the latest version. Reboot the iPhone and you’ll be able to use the new unofficial network. If you’re not sure what to do, follow the instructions below:

How to Unlock iPhone 3GS & iPhone 4 on iOS 5.0.1 with Ultrasn0w

Be sure to confirm baseband firmware before proceeding:

  • Jailbreak iOS 5.0.1 with redsn0w 0.9.9b9 and then boot the iPhone tethered
  • Open Cydia and search for ultrasn0w, installing the ultrasn0w 1.2.5 package onto the iPhone
  • Shut off the iPhone and insert the new SIM card from another carrier
  • Boot the iPhone tethered using redsn0w again
  • Wait for the iPhone to join the new network

Most iPhones won’t be eligible to use this version of ultrasn0w due to the baseband limitation. Keep in mind you can now buy the iPhone 4S unlocked directly from Apple, they aren’t cheap but you won’t have to bother with jailbreaks, software unlocks, or preserving baseband versions between iOS upgrades, and will always be free to use the iPhone on whatever compatible network you have a SIM card for.

Enjoy this tip? Subscribe to the OSXDaily newsletter to get more of our great Apple tips, tricks, and important news delivered to your inbox! Enter your email address below:

Related articles:

Posted by: Matt Chan in iPhone

10 Comments

» Comments RSS Feed

  1. Tao of Dave says:

    Does anyone really need these unlock mods anymore? Just buy an iPhone unlocked if you need it unlocked, that is why Apple sells them. You pay more but it’s about the same cost as you would pay in most other countries for a new phone anyway. Very few places allow onerous 2 year corporate contracts like the USA does, and very few countries citizens would put up with that kind of nonsense! Be a kiwi.

  2. JLD says:

    And what about unlocking ios 5.0.1 on 04.11.08 Baseband. Do you have any kind of news?

  3. Ubicuitate says:

    Hi!
    I have a 3G with Baseband 06.15.00, and after updateing trough cydia to ultrasn0w 1.2.5, my battery drains instantly, my phone only lasts half a day.
    Before updating it lasted 2 days…
    Some help pls…
    TXH!

  4. Nyet says:

    Now you can run KGB software on your iPhone and hear the Kremlin whisper into your ear.

  5. azertred says:

    Hi,
    i have iphone 4 with baseband: 01.59.00

    How can i Update To iOS 5.0.1 Firmware Without Updating Baseband?

    Please help.

    Thanks

    • srsrsr says:

      you need to make a custom ipsw with pwnage tool (read google) be careful.. after that use that in redsnow. .then you maintain thebaseband in case you go on vacation and would like to use your 700 dollar phone to call someone instead of borrowing a hotel phone say.

  6. CEZARE says:

    ULTRASNOW 1.2.5 GONA UNLOCK AND BASEBAND 5.12.01

  7. Aali says:

    Hey..
    I have a 3GS upgraded to 5.0.1..my baseband is 5.16.05..
    My sim isn’t working..can som1 help??

    • Melissa says:

      Hey i have the same exact thing going on here with my 5.0.1 5.16.05 baseband, did you ever figure out how to get yours to work? Mine just says ‘searching’ when i put in my sim card

  8. Jerry says:

    Got question what is the tool to used to unlocked iphone 4 baseband 04.11.08

Leave a Reply

 

Shop for Apple & Mac Deals on Amazon.com

Subscribe to OSXDaily

Subscribe to RSS Subscribe to Twitter Feed Follow on Facebook Subscribe to eMail Updates